読者です 読者をやめる 読者になる 読者になる

Vim で実行する ruby のバージョンについて

Vim 上で ruby を単純に実行するには、:!ruby % を実行すればよいのですが、たまたま Nokogiri でエラーがでてしまった。

`require': no such file to load -- nokogiri (LoadError)

ターミナルから、ruby hoge.rb は実行できているのに。Vimruby のバージョンを確認すると

f:id:ramtiga:20130905030632p:plain

ruby 1.8.7 だった。rbenv で設定している バージョンが指定されていないようだ。

ググってもなかなか見つからない情弱orz.. やっと見つけた以下の記事。

VimからrbenvのRubyが呼び出せない問題が発生してハマった

感謝です! .zshrc にあった以下の記述を、.zshenv に書かないといけないみたい。

if [ -d ${HOME}/.rbenv ] ; then
  PATH=${HOME}/.rbenv/bin:${PATH}
  export PATH
  eval "$(rbenv init -)"
fi

source ~/.zshenv して再度バージョンを確認すると

f:id:ramtiga:20130905030716p:plain

rbenv で設定しているバージョンが指定されました。

開発環境
  • Mac OSX 10.8.4
  • ruby バージョン管理:rbenv
  • zsh 4.3.11