読者です 読者をやめる 読者になる 読者になる

ruby

Vim で実行する ruby のバージョンについて

Vim 上で ruby を単純に実行するには、:!ruby % を実行すればよいのですが、たまたま Nokogiri でエラーがでてしまった。 `require': no such file to load -- nokogiri (LoadError) ターミナルから、ruby hoge.rb は実行できているのに。Vim で ruby のバー…

RubyでTwitterのapiを使ってみる

rubyでTwitterのbot作成依頼などがあり、apiなどを使ってみたのでメモ。まあこれまた今さらネタですけど。環境は、MaxOSX 10.6.7 Ruby 1.9.2 1.Twitterのライブラリをインストール $ gem install twitter 2.Twitterアプリケーション登録申請 botに使いた…

サービスが開始した時に案内をもらう「Notify Me」を試してみた

MOONGIFTさんで紹介されていた、「Notify Me」を試してみた。サービスが開始した時に案内をもらう。メールアドレス登録システム「Notify Me」|オープンソース・ソフトウェア、ITニュースを毎日紹介するエンジニア、デザイナー向けブログ フレームワークはsin…